Iphone 3g

Iphone 3g

Duis ac turpis non lacus varius...
Nokia E63

Nokia E63

Duis ac turpis non lacus varius...
Samsung S8003

Samsung S8003

Duis ac turpis non lacus varius...
Iphone 3g

Iphone 3g

Duis ac turpis non lacus varius...

JV Latest News 

Typography

13 November 2009

Contents overview

09 November 2009

Welcome to Joomla!

12 August 2008

We are Volunteers

07 July 2007

Millions of Smiles

07 July 2007

What are the requirements to run Joomla! 1.5?

PDF列印E-mail

Joomla! runs on the PHP pre-processor. PHP comes in many flavours, for a lot of operating systems. Beside PHP you will need a Web server. Joomla! is optimized for the Apache Web server, but it can run on different Web servers like Microsoft IIS it just requires additional configuration of PHP and MySQL. Joomla! also depends on a database, for this currently you can only use MySQL.

Many people know from their own experience that it's not easy to install an Apache Web server and it gets harder if you want to add MySQL, PHP and Perl. XAMPP, WAMP, and MAMP are easy to install distributions containing Apache, MySQL, PHP and Perl for the Windows, Mac OSX and Linux operating systems. These packages are for localhost installations on non-public servers only.
The minimum version requirements are:
  • Apache 1.x or 2.x
  • PHP 4.3 or up
  • MySQL 3.23 or up
For the latest minimum requirements details, see Joomla! Technical Requirements.